Setting Load Balancing MikroTik Pisah Traffic + Fail Over

Setting Load Balancing MikroTik Pisah Traffic + Fail Over – Artikel ini akan memberikan anda referensi. Bagaimana memisahkan traffic jaringan lokal (LAN) jika mempunyai dua internet service provider (ISP).

Load Balancing Pisah Traffic

Load balancing banyak metode yang bisa dilakukan, tetapi akan dikembalikan lagi kepada kebutuhan kita.

Seperti apakah kebutuhan anda? Apakah ingin menggabungkan koneksi dua (2) ISP menjadi satu? Atau kah ingin memisahkan traffic beberapa client kepada masing-masing ISP?

Semua sudah saya share, semoga memberikan referensi bagi temen-temen. 🙂

Konfigurasi ini meliputi:

  1. IP Address
  2. IP DNS
  3. Address List
  4. Mangle
  5. NAT
  6. IP Route

Step 1 – Konfigurasi IP Address

Disini saya hanya mencontohkan pengaturan IP Address untuk ether1, ether2, dan ether3. Silahkan lihat lagi topologi (gambar) diatas.

/ip address
add address=192.168.10.2/24 interface=ether1-ISPA
add address=192.168.20.2/24 interface=ether2-ISPB
add address=192.168.100.254/24 interface=ether3

Step 2 – Konfigurasi IP DNS

Konfigurasi IP DNS ini untuk resolving query DNS. Disini saya menggunakan Google DNS.

/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4

Step 3 – Konfigurasi Firewall Address List

Bagian ini untuk Grouping client, yang nanti akan diarahkan ke ISP mana. Hanya grouping saja.

/ip firewall address-list
add list=group1 address=192.168.100.1-192.168.100.15
add list=group2 address=192.168.100.16-192.168.100.30
add list=all address=192.168.100.1-192.168.100.30

Step 4 – Konfigurasi Firewall Mangle

Tahap ini merupakan bagian terpenting untuk melakukan marking / penandaan client. Client akan di marking kemana dia keluar untuk terhubung ke internet.

/ip firewall Mangle 
add chain=prerouting src-address-list=all dst-address-list=all action=accept
add chain=prerouting src-address-list=group1 action=mark-routing new-routing-mark=isp_A
add chain=prerouting src-address-list=group2 action=mark-routing new-routing-mark=isp_B

Step 5 – Konfigurasi Firewall NAT

Seperti biasa, konfigurasi firewall nat ini bertujuan untuk memberikan izin ip lokal supaya bisa terhubung ke internet. Letak konfigurasi Fail-Over juga ada disini.

add action=masquerade chain=srcnat out-interface=ether1-ISPA src-address-list=group1
add action=masquerade chain=srcnat out-interface=ether2-ISPB src-address-list=group2
add action=masquerade chain=srcnat out-interface=ether1-ISPA src-address-list=all
add action=masquerade chain=srcnat out-interface=ether2-ISPB src-address-list=all

Step 6 – Konfigurasi IP Route

Bagian ini juga merupakan bagian penting sebagai keputusan konfigurasi firewall mangle.

/ip route
add dst-address=0.0.0.0/0 gateway=192.168.10.1 routing-mark=isp_A check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.20.1 routing-mark=isp_B check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.10.1,192.168.20.1

Oke, demikian sharing mengenai cara load balancing mikrotik pisah traffic + fail over. Apabila ada yang kurang mari kita diskusikan pada kolom komentar dibawah. Terimakasih….

About Ahmad Lukman Hakim 61 Articles
Admin LUKMANLAB, Network Engineer, System Administrator.