Setting Load Balance PCC 2 ISP + Fail Over untuk 1 LAN di MikroTik

Artikel Setting Load Balance PCC 2 ISP + Fail Over untuk 1 LAN di MikroTik akan memberikan konsep yang lebih mudah. Dibanding dengan artikel sebelumnya: Setting Load Balancing PCC 2 ISP + Fail Over Menggunakan MikroTik.

Justru cara ini yang sering saya implementasikan dilapangan. Simplenya untuk load balancing sekaligus fail over dua atau lebih sumber internet (ISP) untuk satu LAN output.

Pada artikel ini saya tidak lagi membahas apa itu load balancing dan fail over. Pembahasan tentang hal tersebut sudah saya tulis pada artikel sebelumnya.

Termonitor visitor untuk artikel tentang load balancing cukup banyak. Jadi, saya ingin menulis lagi dengan konsep yang lebih mudah. Untuk teman-teman yang lagi explore / setting Load Balancing di MikroTik.

Metodenya tetap menggunakan PCC (Per Connection Classifier) karena selama ini cukup bagus saya terapkan.

Topology - Load Balancing PCC 2 ISP + Fail Over untuk 1 LAN
Topology – Load Balancing PCC 2 ISP + Fail Over untuk 1 LAN

Konfigurasi Load Balance PCC 2 ISP + Fail Over Router MikroTik:

1. Setting IP Address

/ip address
add address=202.55.66.2/29 interface=ether1-WAN1 network=202.55.66.0
add address=202.55.77.2/29 interface=ether2-WAN2 network=202.55.77.0
add address=192.168.1.1/24 interface=ether3-LAN network=192.168.1.0

2. Setting DNS

/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4

3. Setting Firewall – NAT

/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1-WAN1 src-address=192.168.1.0/24
add action=masquerade chain=srcnat out-interface=ether2-WAN2 src-address=192.168.1.0/24

4. Setting Firewall – Mangle

/ip firewall mangle
add chain=prerouting src-address=192.168.1.0/24 dst-address=192.168.1.0/24 action=accept
add chain=prerouting src-address=192.168.1.0/24 dst-address=202.55.66.0/29 action=accept
add chain=prerouting src-address=192.168.1.0/24 dst-address=202.55.77.0/29 action=accept

add chain=prerouting connection-mark=no-mark in-interface=ether1-WAN1 action=mark-connection new-connection-mark=ISP-A_conn
add chain=output connection-mark=ISP-A_conn action=mark-routing new-routing-mark=via-ISP-A
add chain=prerouting connection-mark=no-mark in-interface=ether2-WAN2 action=mark-connection new-connection-mark=ISP-B_conn
add chain=output connection-mark=ISP-B_conn action=mark-routing new-routing-mark=via-ISP-B

add chain=prerouting src-address=192.168.1.0/24 per-connection-classifier=both-addresses:2/0 action=mark-connection new-connection-mark=ISP-A_conn passthrough=yes
add chain=prerouting src-address=192.168.1.0/24 connection-mark=ISP-A_conn action=mark-routing new-routing-mark=via-ISP-A passthrough=yes

add chain=prerouting src-address=192.168.1.0/24 per-connection-classifier=both-addresses:2/1 action=mark-connection new-connection-mark=ISP-B_conn passthrough=yes
add chain=prerouting src-address=192.168.1.0/24 connection-mark=ISP-B_conn action=mark-routing new-routing-mark=via-ISP-B passthrough=yes

5. Setting Route

/ip route
add dst-address=0.0.0.0/0 gateway=202.55.66.1 routing-mark=via-ISP-A check-gateway=ping
add dst-address=0.0.0.0/0 gateway=202.55.77.1 routing-mark=via-ISP-B check-gateway=ping
add dst-address=0.0.0.0/0 gateway=202.55.66.1,202.55.77.1
About Ahmad Lukman Hakim 61 Articles
Admin LUKMANLAB, Network Engineer, System Administrator.