Konfigurasi MikroTik untuk External Proxy

External Proxy

External Proxy menurut saya adalah Server Proxy yang diletakkan diluar dari router ataupun proxy server itu sendiri.

Kalau dilihat pada gambar topologi tersebut, PC Server hanya menggunakan 1 (satu) NIC.

Jadi, router MikroTik disini difungsikan untuk mengatur traffict client supaya ketika mengakses internet (browsing) itu secara otomatis (transparent) ke Proxy Server dulu baru bisa akses ke Internet.

Untuk bisa transparent seperti ini, tentu didukung dengan konfigurasi Proxy Server yang transparent juga. Biasanya ada penambahan option “transparent” pada bagian http_port 3128 => (http_port 3128 transparent).

Selain option tersebut kita juga perlu konfigurasi firewall pada Proxy Server tersebut, biasanya memakai bantuan iptables ataupun command firewall lain untuk melakukan NAT supaya bisa ke port 3128 (proxy) setiap ada yang mengakses port 80 (http).

Topology

Gambar Topology

Langkah-langkah Konfigurasi MikroTik untuk External Proxy

1. Konfigurasi Mangle

Kita tandai dulu traffict yang berasal dari IP Address Client 192.168.100.0/24 dengan Mark Routing yang nantinya kita akan pakai untuk mengatur routingnya supaya ke External Proxy.

/ip firewall mangle add action=mark-routing chain=prerouting comment="mark routing to proxy" dst-port=80 new-routing-mark=to-ext-proxy protocol=tcp src-address=192.168.100.0/24

2. Konfigurasi Route

Kita buat default route dengan Gateway IP Address Proxy Server dari Traffict yang sudah ditandai tadi. Disinilah keputusanya supaya client itu traffict-nya ke External Proxy dulu untuk bisa terhubung ke Internet.

/ip route add check-gateway=ping distance=1 gateway=192.168.200.2 routing-mark=to-ext-proxy

Silahkan rule tersebut di copas dulu ke notepad dan dicustomize sesuai dengan jaringan anda masing-masing. Selanjutnya silahkan copas ke MikroTik, jika menggunakan Winbox silahkan paste di New Terminal, kalau MikroTiknya di Console menggunakan Telnet / SSH langsung paste aja di terminal Console-nya..

3. Konfigurasi pada Proxy Server

Setelah selesai konfigurasi pada sisi mikrotik, anda perlu konfigurasi juga pada sisi proxy server. Proxy server disini karena hanya menggunakan 1 port ethernet maka ada rule iptables yang perlu diatur.

Berikut rule iptables-nya:

# route add default gateway 192.168.200.1
# iptables -A PREROUTING -t nat -j REDIRECT -p tcp -s 192.168.100.0/24 -d 0/0 --dport 80 --to-ports 3128
# iptables -A INPUT -p tcp -s 0.0.0.0/0 -d 192.168.200.2 -m state --state NEW,ESTABLISHED -j ACCEPT
# iptables -A OUTPUT -p tcp -s 192.168.200.2 --sport 3128 -d 0.0.0.0/0 -m state --state ESTABLISHED -j ACCEPT

Note: Rule ini alhamdulillah sudah saya uji, kebetulan rule tersebut yang working daripada menggunakan NAT ataupun NAT + Web Proxy (parent proxy).

Sekian & Terimakasih…

Salam Ngoprek.

About Ahmad Lukman Hakim 72 Articles
Admin LUKMANLAB, Network Engineer, System Administrator.